We are not receiving some of our lookalike data

Incident Report for Red Sift UK

Postmortem

At 11:24 UTC on 2025-07-23 our monitors detected we had stopped receiving data on the service that feeds Brand Trust lookalikes.
After further investigation it was decided that this was a partial outage only, since we have other sources of data.
Even further investigation confirmed that data was being received but the metrics used to monitor it were not. So while we were still processing data, we were unaware of it.

The incident was closed at 11:54. There was no customer impact or no data loss.

Posted Nov 28, 2025 - 12:29 UTC

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 11:54 UTC

Investigating

We are currently investigating the issue with our technology partner.
Posted Jul 23, 2025 - 11:24 UTC
This incident affected: Brand Trust (Web Application and APIs, Infrastructure).