Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 21, 2026 - 08:30 UTC
Scheduled
We will be updating our load balancers tomorrow, and expect a small (less than five minute) downtime window. No impact on report processing, or DNS services.
Posted Feb 20, 2026 - 10:19 UTC
This scheduled maintenance affected: OnDMARC (Web Application and APIs), Brand Trust (Web Application and APIs), and Certificates (Web Application and APIs).