Our provider reports that mitigation efforts are working. We will mark it as resolved and keep monitoring the situation
Posted Aug 11, 2025 - 14:38 UTC
Investigating
Our cloud service provider in the UK is experiencing failures affecting service availability and performance. We are monitoring the situation and so far this has not affected our service. We continue to monitor the situation while our provider investigates it.
Posted Aug 11, 2025 - 13:48 UTC
This incident affected: OnDMARC (Web Application and APIs, Infrastructure, Dynamic Services), Brand Trust (Web Application and APIs, Infrastructure), and Certificates (Web Application and APIs, Infrastructure).