This incident is now resolved. Access to the Red Sift platform (UI and API) on our UK-hosted environment has been stable for over an hour. No action is required on your end.
Posted Aug 03, 2026 - 17:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 03, 2026 - 15:25 UTC
Monitoring
We've applied a mitigation for the intermittent access issues affecting the Red Sift platform (UI and API) on our UK-hosted environment. Access has stabilized and we're continuing to monitor. No action is required on your end. We'll post a final update once we've confirmed the issue is fully resolved.
Posted Aug 03, 2026 - 15:09 UTC
Identified
Customers on our UK-hosted environment may experience intermittent issues accessing the Red Sift platform, including the dashboard and API. We've identified the cause and are working on mitigation. No action is required on your end.
Posted Aug 03, 2026 - 14:35 UTC
This incident affected: OnDMARC (Web Application and APIs), Red Sift Web Portal, Brand Trust (Web Application and APIs), and Certificates (Web Application and APIs).