A fix has been implemented. Services are coming back. We are monitoring.
Posted Jun 03, 2026 - 01:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2026 - 01:09 UTC
Update
We are continuing to investigate this issue.
Posted Jun 03, 2026 - 00:38 UTC
Investigating
Some customers are currently experiencing issues logging in and using our services. We are investigating
Posted Jun 03, 2026 - 00:38 UTC
This incident affected: OnDMARC (Web Application and APIs), Red Sift Web Portal, Brand Trust (Web Application and APIs), and Certificates (Web Application and APIs).