The issue has been resolved and all services are operating normally.
Thank you for your patience.
Posted Jan 09, 2026 - 11:21 UTC
Monitoring
We have implemented a fix and functionality has been restored. We are continuing to monitor and working with the upstream provider on the underlying connectivity issue.
Posted Jan 09, 2026 - 10:51 UTC
Identified
We are experiencing connectivity issues with an upstream infrastructure provider affecting some functionality.
Current impact on Brand Trust: - Management of faces and logos is unavailable - Activity page may take significantly longer to load (up to 60 seconds)
We have escalated to the provider and are awaiting their response. We will post updates as we learn more.
Posted Jan 09, 2026 - 10:45 UTC
This incident affected: Brand Trust (Web Application and APIs, Infrastructure).