Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 21, 2026 - 07:00 UTC
Scheduled
We will be performing planned infrastructure upgrades and patching on the systems that power OnDMARC, BrandTrust, and Certificates in our UK region. This work is part of our ongoing efforts to keep the underlying platform secure and up to date. During this time, you may experience brief networking interruptions or slowdowns; no full outage is expected and no action is required.
Posted Jul 14, 2026 - 10:01 UTC
This scheduled maintenance affected: OnDMARC (Web Application and APIs, Infrastructure), Brand Trust (Web Application and APIs, Infrastructure), and Certificates (Web Application and APIs, Infrastructure).